Our extensions work with Joomla 3.1.x to 3.6.x, and with PHP 5.3 to 5.6, and 7. Sites run noticably faster with PHP 7.

We no longer support our extensions under Joomla 1.x, 2.x, or 3.0.

We continue to provide some extensions that run under Joomla 2.5, however, if you are still using 2.5 you should upgrade as soon as possible. Support for Joomla 2.5 officially ended on December 31st, 2014. Major new versions of our software require at least Joomla 3.1.1. We will make older versions that support Joomla 2.5 available until the end of 2016, but the old versions will no longer be enhanced with new features. Dropping support for Joomla 2.5 enables us to remove old code, allows us to take full advantage of the responsive administration interface, and helps to prepare for future versions of Joomla.

We will do our best to help you if you have a problem with one of our extensions in an older version of Joomla, but our memory of Joomla prior to version 3 is fading and if you encounter a tricky problem, we will ask you to upgrade to a newer version of Joomla and the latest version of our product.

We strongly recommend that you keep your site up to date with the latest version of Joomla. From time to time significant security issues emerge, and sites that are not updated are quickly attacked once details of the problem are published. In general you can assume that our extensions work on new minor releases of Joomla, but if your site is critical to your business you should have a parallel test site where you can test upgrades before implementing them in your live site.

There's a handy table of Joomla versions and support dates at http://docs.joomla.org/Joomla!_CMS_versions

All free and paid downloads on this site are managed by MediaShop

Vox Mortuis