Browsers

We now do most of our development using Google Chrome. We also test extensively using Firefox, and to a lesser extent, IE and Safari. If you find a problem with any of our extensions using any of those browsers, please tell us. We don't routinely test in Opera but we will attempt to fix any reported issues.

At the front end, all of our extensions should produce HTML that validates as HTML5. If you discover an HTML validation error, please tell us and we will fix it. We don't worry so much about validating the back end, but if you find something that renders incorrectly, please tell us and we will fix it. We validate to CSS 3.0 where possible, but at this time it's not sensible to have a policy of strict validation.

PHP and MySql

We develop and test using PHP 5.3 on Windows and PHP 5.4 on Linux. We use PHP error reporting set to E_ALL| E_STRICT, which means that our released code should not issue any errors or notices. If you see any errors or notices, please tell us and we will fix them. Although Joomla 2.5 supports PHP 5.2, we do not test on such old versions of PHP. If you are using PHP older than 5.3, you should upgrade. We do not support PHP 4 or MySql 4.

Databases

Joomla 2.5 and 3.x now support other databases besides just MySql. Our extensions only support MySql. If this is an issue for you, please let us know. If we receive a significant number of requests to support different databases, we will have to decide what to do.

Javascript Frameworks

Most of our extensions use small snippets of standard Javascript to improve the user experience. There is nothing unusual in that and it shouldn't cause any problems. Unfortunately, more advanced user interfaces, like popup date pickers, advanced menus and photo galleries, usually need help from a Javascript library, or "framework". There are lots of Javascript frameworks, two of the most popular being Mootools and JQuery. Unfortunately they come in different versions, and code written for one version does not necessarily work properly in other versions. These are the versions that Joomla loads:

Joomla 1.5 < 1.5.19 Mootools 1.1
Joomla 1.5 > 1.5.19 with the Mootools Upgrade plugin enabled Mootools 1.2
Joomla 1.6 Mootools 1.3
Joomla 1.7 Mootools 1.3.2
Joomla 2.5 Mootools 1.4 with its 1.2 and 1.3 compatibility layer
Joomla 3.0 Mootools 1.4 without its compatibility layer
JQuery 1.8.1
Joomla 3.1 Mootools 1.4 without its compatibility layer
JQuery 1.10.2
Joomla 3.2 Mootools 1.4 without its compatibility layer
JQuery 1.10.2

Some templates and extensions also load additional Javascript frameworks, or additional versions, and this can easily lead to conflicts that may prevent one or more extensions from working properly. The result is that some extensions are incompatible with some templates, and some extensions are incompatible with other extensions. It can be difficult and frustrating to resolve these issues, and the more extensions you add to your site the more likely it is that you will encounter a problem.

We are careful to adhere to the best possible practices in our usage of Javascript frameworks, but we can't be responsible for Javascript compatibility issues on your website. If you are building a complex site with lots of complex extensions, be prepared to spend some time resolving Javascript compatibility issues. With a complex site you really need to add features and extensions one by one, testing as you go.

 

 

MediaShop

All free and paid downloads on this site are managed by MediaShop

Vox Mortuis

Downloads in the last 7 days