Most of our extensions work with Joomla 3.4.8 to 3.8.x. Rentalot Plus, MediaShop, and Payage require at least Joomla 3.7.0. Older versions of our paid extensions are available on request. We have been working towards support for Joomla 4 and are currently testing with a pre-release of Joomla 4.

We no longer provide extensions for Joomla 2.5 except for Eyesite, which will remain available for Joomla 2.5 until the end of 2017.

We will not provide support for old versions of our products or old versions of Joomla.

We strongly recommend that you keep your site up to date with the latest version of Joomla. From time to time significant security issues emerge, and sites that are not updated are quickly attacked once details of the problem are published. In general you can assume that our extensions work on new minor releases of Joomla, but if your site is critical to your business you should have a parallel test site where you can test upgrades before implementing them in your live site.

We will always offer our best advice, but if you want us to research a complex or time-consuming problem, it must be on the latest version of Joomla with the latest version of our product.

There's a table of Joomla versions and support dates at!_CMS_versions

Our extensions work with PHP 5.3 to 5.6, and PHP 7. If you have not yet upgraded to PHP 7 you should make plans to do so. Sites run noticeably faster with PHP 7, and Joomla 4 requires PHP 7 as a minimum.