Most of our extensions now require a minimum of Joomla 3.7.0 due to our ongoing preparation for Joomla 4. If you use an old version of Joomla 3 we can provide old versions of our paid extensions on request, but without support. We no longer have any extensions that work with Joomla 2.5.

All of our extensions will be ready for Joomla 4 well before its release. According to the Joomla Project Roadmap, a stable release is scheduled for the 4th quarter of 2018.

We strongly recommend that you keep your site up to date with the latest version of Joomla. From time to time significant security issues emerge, and sites that are not updated are quickly attacked once details of the problem are published. In general you can assume that our extensions work on new releases of Joomla, but if your site is critical to your business you should have a parallel test site where you can test upgrades before implementing them in your live site.

We will always offer our best advice, but if you want us to research a complex or time-consuming problem, it must be on the latest version of Joomla with the latest version of our product. We will not spend time trying to solve problems that we believe may be caused by running old versions of software.

There's a table of Joomla versions and support dates at http://docs.joomla.org/Joomla!_CMS_versions

We develop and test our extensions primarily on PHP 7, although we also maintain compatibility with PHP 5.3 to 5.6. If you have not yet upgraded to PHP 7 you should do so. Sites run noticeably faster with PHP 7, and Joomla 4 requires PHP 7 as a minimum.