Les Arbres Web Solutions

Joomla 3

Our extensions require a minimum of Joomla 3.7.0 and we test all our extensions with the latest versions of Joomla as they become available. If you use an older version of Joomla 3 we can provide older versions of our paid extensions on request. We no longer supply versions for Joomla 2.5.

We recommend that you keep your site up to date with the latest version of Joomla. From time to time security issues emerge, and sites that are not updated may be attacked once details of the problem are published. In general you can assume that our extensions work on new releases of Joomla, but if your site is critical to your business you should have a test site where you can test upgrades before implementing them in your live site.

There's a useful table of Joomla versions and support dates at http://docs.joomla.org/Joomla!_CMS_versions

Joomla 4

All of our extensions have been fully tested and work well in the Joomla 4 Beta versions. We test with the latest Beta releases as they become available and apply fixes as needed. As yet there is still no firm release date for Joomla 4. The Joomla Project Roadmap has more information.

PHP

We develop and test our extensions on PHP 7.3 and 7.4. We will try to maintain compatibility with PHP 5.6 for as long as possible, but we don't test on it. Support for PHP 5.6 ended in 2018.

If you haven't already upgraded to PHP 7 we strongly recommend that you do so. Sites run much faster with PHP 7, and Joomla 4 requires it.

There's a useful table of PHP versions and support dates at https://www.php.net/eol.php

PHP 8 was released in November 2020. We have started testing with it and don't expect any major issues, however we think it's too soon to use PHP 8 on a live site because many extensions won't have been tested on it yet.

Databases

We develop and test using MySql 5.6. Although Joomla 3 added support for SQL Server and PostgreSQL, our extensions only support MySql (and MariaDB).

Joomla 4 has dropped support for SQL Server, and it seems likely that support for PostgreSQL will eventually be dropped. Testing and supporting our extensions in PostgreSQL would be a huge overhead with no benefit, so our extensions refuse to install if the site database is anything other than MySql.